Windows 3.1x Support Forum

Registrieren || Einloggen || Hilfe/FAQ || Suche || Memberlist || Home || Statistik || Kalender || Staff Willkommen Gast!
[ win31.de ] [ Impressum/Kontakt ] [ Über das Forum/Regeln ]

Windows 3.1x Support Forum » Installation und Konfiguration » Win 3.11 will nicht mehr » Threadansicht

Autor Thread - Seiten: -1- [ 2 ] [ 3 ]
000
12.12.2011, 18:05 Uhr
Nuwi



Hallo, wir betreiben in meiner Abteilung noch ein Messgerät, welches nur unter DOS 6.22 und Win3.11 läuft. Leider will der Rechner seit heute nicht mehr hochfahren. DOS startet, dann gibt er aber das gespeicherte Datum an und will das gegenwärtige eingegeben haben (das Datum, das er angibt ist aber schon das korrekte). Dann das gleiche mit der Uhrzeit, dann erscheint c: und anders als üblich fährt Windows nicht automatisch hoch

Versuche es dann per manueller Eingabe zu starten scheitern ....das Windowsverzeichnis ist natürlich weiterhin vorhanden, eine Windows.exe-datei finde ich allerdings nicht. Eine Himem.sys ist ebenfalls vorhanden. (ich kann mir auch schwerlich vorstellen, dass eine Datei unabsichtlich gelöscht wurde)

Deutet das eher auf ein Hardware oder ein Softwareproblem hin?
Als Win das letzte mal lief war es eingefroren und auch Alt-Strg-Entf half nicht, sodass sie radikale Variante Power-off gewählt wurde.

Vielleicht hat ja einer ne Idee oder kann mir Tipps geben wie ich die Sache systematisch eingrenzen kann, bin leider völlig unerfahren was Dos/3.1 angeht.
Falls das Ganze zu wenig detailliert beschrieben wurde kann ich Rückfragen gerne noch zeitnah beantworten.

Schon mal Vielen Dank!

Jogi
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
001
12.12.2011, 19:15 Uhr
Aqua



Hallo Jog!

Führe Scandisk unter Dos aus, um defekte Festplattensektoren mal auszuschliessen.
Und poste bitte mal deine Autoexec.bat und Config.sys.
Weisst du noch den Namen der besagten Windows.exe Datei ?
--
Generic USB Massenspeichertreiber: DOS/Win3.1x-USB1+2 Win95B-USB1+Win95BUSBSupp Win98FE-USB1+2
Win98SE-USB1+2 WinNT4.0-USB1 DOS-PCMCIA-ATA bis zu 4 Sockets(Cardbus kompatibel) My pimped DOS6-WIN3 All4Win3-MP3

Dieser Post wurde am 12.12.2011 um 19:18 Uhr von Aqua editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
002
12.12.2011, 20:55 Uhr
Antz

Avatar von Antz

Wenn Dos nach Uhrzeit und Datum fragt, sind die Startdateien ex (config.sys u. autoexec.bat),
dadurch wird auch der Windows-Startbefehl nicht gefunden (win.com, weil die Pfadangaben in der autoexec.bat stehen),
ganz abgesehen, welche Treiber noch in der config.sys geladen wurden (evtl. für das Messgerät)
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
003
13.12.2011, 14:35 Uhr
Nuwi



Danke Euch beiden schon mal für die Hilfe. Scandisk hat keine Auffälligkeiten gezeigt. Die Autoexec.bat und die Config.sys sind vorhanden. Komischerweise erhalte ich aber wenn ich sie im DOS-Editor öffne einen leeren Bildschirm. Wenn ich sie auf Diskette kopiere und dann auf einem anderen 3.1 Rechner mit dem Editor öffne erscheinen die unten angegbenen Angaben (habe definitiv edit a: eingegeben, es sind also die Dateien vom "Problemrechner")
@Aqua: die Frage mit dem windows.exe verstehe ich nicht ganz, ich meinte damit, dass man doch mit der Eingabe "WIN" Windows aus DOS starten kann und bin davon ausgegangen, dass die zugehörige Datei Windows.exe ist...
Sorry, wie erwähnt hab ich von DOS/3.X nicht soviel Ahnung.....

config.sys
DEVICE=C:\DOS\SETVER.EXE
DEVICE=C:\DOS\HIMEM.SYS
DOS=HIGH
COUNTRY=049,850,C:\DOS\COUNTRY.SYS
DEVICE=C:\DOS\DISPLAY.SYS CON=(EGA,,1)
FILES=30


autoexec.bat
C:\DOS\SMARTDRV.EXE /X
@ECHO OFF
PROMPT $P$G
PATH C:\DOS
SET TEMP=C:\DOS
MODE CON CODEPAGE PREPARE=((850) C:\DOS\EGA.CPI)
MODE CON CODEPAGE SELECT=850
KEYB GR,,C:\DOS\KEYBOARD.SYS

Dieser Post wurde am 13.12.2011 um 14:50 Uhr von Nuwi editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
004
13.12.2011, 14:59 Uhr
Nuwi



Noch als Ergänzung, um auszuschliessen dass das mit meinem Problem zusammenhängen könnte:

die Inhalte von Config.sys und Autoexec.bat werden weiterhin nicht angezeigt wenn ich sie vom "Problemrechner" über edit c: öffnen möchte.....die selben Dateien die ich aber von c: auf a: kopiert habe um sie an einem anderen Rechner zu öffnen lassen sich über edit a: jetzt auch auf dem "Problemrechner" anschauen...

(hoffe das war verständlich)

Gruss

Jogi
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
005
13.12.2011, 15:36 Uhr
Aqua



Füge mal unter die Zeile
DEVICE=C:\DOS\HIMEM.SYS
DEVICE=C:\DOS\EMM386.EXE NOEMS
in der Config.sys hinzu..

Achso dachte du meintest eine bestimmte EXE Datei.
Win.com kann nicht gefunden werden ?
Könnte sein, dass in der Autoexec.bat ein SET PATH=C:\WINDOWS Befehl oder dergl fehlt.

PS: 'C : \' sollte es zusammengeschrieben heissen

Ist unter Dos ein Norton Commander installiert?
ZB NC Verzeichnis aufgelistet mit Eingabe von DIR
Der NC zeigt nämlich an, ob die Konfigurationsdateien eventuell versteckte Dateiattribute aufweisen, warum auch immer.
(Kann man mit dem NC auch auf einfache Weise ändern, auf Eingabeebene ist's für nen Laien nämlich etwas komplizierter)
Könnte ein Grund sein, warum die nicht geladen werden bzw nicht angezeigt werden können auf dem lokalen Dos Rechner.
--
Generic USB Massenspeichertreiber: DOS/Win3.1x-USB1+2 Win95B-USB1+Win95BUSBSupp Win98FE-USB1+2
Win98SE-USB1+2 WinNT4.0-USB1 DOS-PCMCIA-ATA bis zu 4 Sockets(Cardbus kompatibel) My pimped DOS6-WIN3 All4Win3-MP3

Dieser Post wurde am 15.12.2011 um 08:11 Uhr von DosAmp editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
006
13.12.2011, 16:36 Uhr
Nuwi



Danke, die config.sys sieht jetzt also so aus:

DEVICE=C:\DOS\SETVER.EXE
DEVICE=C:\DOS\HIMEM.SYS
DEVICE=C:\DOS\EMM386.EXE NOEMS
DOS=HIGH
COUNTRY=049,850,C:\DOS\COUNTRY.SYS
DEVICE=C:\DOS\DISPLAY.SYS CON=(EGA,,1)
FILES=30

aber immer noch Datums- und Uhrzeitabfrage und kein Windows-Start :-(

Dieser Post wurde am 13.12.2011 um 16:36 Uhr von Nuwi editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
007
13.12.2011, 18:18 Uhr
Aqua





Guck mal, ob ein solches Programm auf dem Rechner ist, das wäre dir beim Konfigurieren sehr hilfreich.
Wie es scheint, werden Autoexec.bat und Config.sys schlicht nicht geladen.
Prüfe mal die Dateiattribute von Beiden und sieh nach ob die Command.com überhaupt existiert.
--
Generic USB Massenspeichertreiber: DOS/Win3.1x-USB1+2 Win95B-USB1+Win95BUSBSupp Win98FE-USB1+2
Win98SE-USB1+2 WinNT4.0-USB1 DOS-PCMCIA-ATA bis zu 4 Sockets(Cardbus kompatibel) My pimped DOS6-WIN3 All4Win3-MP3

Dieser Post wurde am 13.12.2011 um 18:19 Uhr von Aqua editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
008
14.12.2011, 16:11 Uhr
Nuwi



Danke für die Unterstützung Aqua

DOSRAR ist leider nicht drauf, gibts die Möglichkeit das noch aufzuspielen, mit mehreren Disketten??? oder ich hätte auch noch ein Parallel-Zip100. Hab aber keine Ahnung ob ich das unter DOS zum laufen bekomme.

Die COMMAND.COM existiert und liegt ebenfalls in C:\DOS

Habe zuletzt jetzt noch die win.com gesucht und gefunden. Wenn ich die laufen lassen will wird dann gemeckert dass die Himem.sys in C:\Windows nicht gefunden wird bzw. ggf. der Verweis darauf in der Config.sys nicht stimmt. Da die bei mir ja in C:\dos liegt hab ich sie vorsichtshalber mal nach C:\Windows verschoben und auch den Verweis in Config.sys entsprechend geändert.
Trotzdem findet er angeblich Himem.sys nicht in C:\Windows

die Config.sys sieht jetzt so aus:


DEVICE=C:\DOS\SETVER.EXE
DEVICE=C:\WINDOWS\HIMEM.SYS
DEVICE=C:\DOS\EMM386.EXE NOEMS
DOS=HIGH
COUNTRY=049,850,C:\DOS\COUNTRY.SYS
DEVICE=C:\DOS\DISPLAY.SYS CON=(EGA,,1)
FILES=30

hätte ich da sonst noch was ändern müssen?

Dieser Post wurde am 14.12.2011 um 16:11 Uhr von Nuwi editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
009
14.12.2011, 19:31 Uhr
Antz

Avatar von Antz

Da die config.sys auf der Platte nicht gefunden wird, kann himem.sys auch nicht geladen werden, da beisst sich die Maus in den Schwanz.

Schau mal, welche Dos-Version du da hast, einfach VER eintippen.
Dann könntest du mit einer passenden Bootdisk die Systemdateien neu auf die Platte schreiben.
Irgendwas muss ja kaputtgegangen sein, weswegen Dos beim Start die config.sys und autoexec.bat ignoriert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
010
14.12.2011, 21:38 Uhr
Aqua



@Nuwi:
Dosrar brauchst dazu eh nicht, du willst ja nichts packen oder entpacken.. ,
der Bildschirm stellt den Norton Commander dar - ist eine Benutzeroberfläche für Dos.
Den meinte ich eigentlich.
Auf meinem Screen als NC4 (Norton Commander Version 4.0),
NC5 (Norton Commander Uersion 5.0) und NC55 (Norton Commander Version 5.5) zu finden.
Die linke Seite des Bildschirms zeigt auch den Root meiner MS-DOS 6.22 Partition.
Auf die rechte Seite brauchst nicht blicken, weil das sind 2 andere installierte Betriebssysteme.

Dumme Frage: Liegen die Autoexec.bat und Config.sys eh am Root - also auf C : \ ?
(und nicht fälschlicherweise im Windows Verzeichnis/Ordner oder sonstigen Ordner)

@Antz: Wegen des VER Befehls:
Nun es wird ihm ja doch kein boshafter Mensch Dos 1.0 oder 2.0 untergeschoben haben, aber wer weiss...
Oder gar einen alten Dos Virus, mit einer Floppy ginge das alles ganz leicht..

@Nuvi: Steht besagter PC in einer Firma ?
Wenn JA - muss den ja mal jemand eingerichtet haben, existiert dieser Mensch noch ?
--
Generic USB Massenspeichertreiber: DOS/Win3.1x-USB1+2 Win95B-USB1+Win95BUSBSupp Win98FE-USB1+2
Win98SE-USB1+2 WinNT4.0-USB1 DOS-PCMCIA-ATA bis zu 4 Sockets(Cardbus kompatibel) My pimped DOS6-WIN3 All4Win3-MP3

Dieser Post wurde am 14.12.2011 um 22:46 Uhr von Aqua editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
011
15.12.2011, 10:48 Uhr
Nuwi



Hi,

-die Autoexecbat.bat und Config.sys liegen in C:\dos....ich nehme an das gehört so!?

-Die DOS Version ist 6.20 (nicht wie eingangs geschrieben DOS 6.22)

-Der Mensch der die Maschine ind der Firma mal aufgesetzt hat ist in Rente....wen wundert's :-). Wie es in grossen Firmen so ist: Anruf beim IT-Helpdesk ergibt:"3.1X-Rechner? supporten wir nicht mehr"

-Ich werd noch ein paar Sachen probieren und ansonsten ggf. probieren einen externen IT-Dienstleister zu bekommen (werden sicher auch begeistert sein wenn sie 3.1 hören). Alternativ müssten wir neu aufsetzen, dann müsste allerdings der Techniker für das Messgerät zum Einrichten kommen....wird auch nicht billiger.

-Noch ne Frage zur "Bootdiskette": hab ich natürlich nicht und dachte sowas gäbe es für Win 3.X auch gar nicht?! Oder gibt's da was "universelles"?

-Hardware kann man Eurer Meinung ausschliessen? Dachte zuerst an irgendwelche Batterien (wg. Uhrzeitabfrage) oder RAM....aber dann würde vermutlich auch kein DOS booten. Dann schraub ich das gute Stück mal wieder zu.

Ich schau dann mal noch ob ich NC noch draufspielen kann....wenn ich DOSRAR nicht brauche ;-)

THX

Dieser Post wurde am 15.12.2011 um 10:49 Uhr von Nuwi editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
012
15.12.2011, 17:40 Uhr
Aqua



Kopiere die Autoexec.bat und Config.sys auf C und boote dann noch mal..

Bootdisketten kann man selbstverständlich auch mit CD-Rom, Netzwerktreibern, Usb Support..etc etc.. kreiern, nur muss man dazu selbst Hand anlegen.
Etwas "Fertiges" gibt's dazu nicht, aber grad darin liegt ja der Reiz einer Dos/Win3.x Konfiguration.
Man kann sich damit sein komplett eigenes Ding zusammenbasteln, wie aus in einer Kiste vollgepackt mit Legobausteinen.
Umso voller natürlich diese Kiste, umso farbenreicher und formvielfältiger die Bausteine sind, desto besser.
Die Kunst darin besteht, die richtigen Bausteine miteinander zu kombinieren..
(um es mal anders zur besseren Verständlichkeit zu formulieren -g-)

Mit dem Befehl Sys A: kannst du jedenfalls die Dos Systemdateien auf eine Disk kopieren und kannst mit dieser Diskette dann auch booten..

Mit *.Bat Dateien kann man Tastenbelegungen ganz nach eigenen Wünschen gestalten.. Und so weiter und so weiter..
--
Generic USB Massenspeichertreiber: DOS/Win3.1x-USB1+2 Win95B-USB1+Win95BUSBSupp Win98FE-USB1+2
Win98SE-USB1+2 WinNT4.0-USB1 DOS-PCMCIA-ATA bis zu 4 Sockets(Cardbus kompatibel) My pimped DOS6-WIN3 All4Win3-MP3

Dieser Post wurde am 15.12.2011 um 18:29 Uhr von Aqua editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
013
16.12.2011, 15:26 Uhr
Antz

Avatar von Antz

autoexec.bat und config.sys müssen in C:\ liegen, nirgendwo anders.
Wenn die Dateien dort gefehlt haben, muss da irgendwas schief gelaufen sein.
Wenn, dann war es ein Glücksfall (oder weise Vorraussicht), wenn in C:\Dos Sicherheitskopien liegen.
Kopier die mal nach C:\ ,leicht möglich, dass dann alles wieder funktioniert, Scandisk hast ja schon drüberlaufen lassen (Um eventuelle Schäden an der Festplatte auszuschliessen).

Dieser Post wurde am 16.12.2011 um 15:26 Uhr von Antz editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
014
16.12.2011, 16:09 Uhr
Nuwi



Hi, konnte mich heute leider nicht intensiv um das Problem kümmern. Ein bisschen hat mich die Verschiebung von Config.sys und Autoexec.bat weitergebracht. Er fragt jetzt nicht mehr nach der Uhrzeit lädt dann:

"Himem testet den erweiterten Speicher....
C:\>C:\smartdrv.exe /X
Mode Codeseite vorbereiten Funktion ausgeführt
Mode Codeseite auswählen Funktion ausgeführt"


dann kommt aber wieder C:\ und nix passiert, gebe ich dann win.com ein erhalte ich:

"Kann Win386.exe benötigt um 386 erweiterten Modus auszuführen nicht finden.Stellen Sie sicher, dass der Pfad richtig ist oder installieren Sie Windows neu"

Win386.exe liegt in C:\Windows\system. Muss ich die auch verschieben oder muss ich einen Verweis ändern?

Hier nochmal die Config.sys und autoexec.bat wie sie jetzt in C:\ liegen:

config.sys
DEVICE=C:\DOS\SETVER.EXE
DEVICE=C:\DOS\HIMEM.SYS
DOS=HIGH
COUNTRY=049,850,C:\DOS\COUNTRY.SYS
DEVICE=C:\DOS\DISPLAY.SYS CON=(EGA,,1)
FILES=30


autoexec.bat
C:\DOS\SMARTDRV.EXE /X
@ECHO OFF
PROMPT $P$G
PATH C:\DOS
SET TEMP=C:\DOS
MODE CON CODEPAGE PREPARE=((850) C:\DOS\EGA.CPI)
MODE CON CODEPAGE SELECT=850
KEYB GR,,C:\DOS\KEYBOARD.SYS

Dieser Post wurde am 16.12.2011 um 16:10 Uhr von Nuwi editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
015
16.12.2011, 16:41 Uhr
Antz

Avatar von Antz

So wie die autoexec.bat aussieht, wurden die Sichertheitskopien vor der Installation von Windows gemacht.
Sollte aber nicht tragisch sein,
Schreib in der autoexec.bat in der "PATH"-Zeile den Windows-Pfad dazu,
sollte dann so aussehen:
PATH C:\DOS;C:\WINDOWS
Damit sollte der Start von win.com dann auch von c:\ aus möglich sein und alles gefunden werden.
Wenn nicht, hat es möglicherweise auch ein paar Windows-Dateien erwischt.

Dieser Post wurde am 16.12.2011 um 16:41 Uhr von Antz editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
016
16.12.2011, 17:26 Uhr
Nuwi



Nun er kommt jetzt so weit, dass ich schon mal kurz das WINDOWS Fenster sehe aber dann fällt er in DOS zurück und fragt z.B. nach

CPWIN386.CPL diese Datei liegt in C:\Windows\System. Wenn ich die in C:\ verschiebe fragt er nach erneutem Start nach einer anderen 386 Datei: Serial.386......kurzum alle Dateien die er nicht findet liegen in C:\Windows\System. Muss ich die jetzt einzeln dorthin kopieren oder kann ich das über einen Verweis in der autoexec.bat machen?

Fragt mich bitte nicht wie die ganzen Dateien an den falschen Ort kommen...keine Ahnung!

Danke!!!

Dieser Post wurde am 16.12.2011 um 17:41 Uhr von Nuwi editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
017
16.12.2011, 22:15 Uhr
commander_keen

Avatar von commander_keen

Die sind nicht an einem falschen Ort, die gehören ins Windows-Verzeichnis und nicht direkt unter C:\ ins Wurzelvberzeichnis.
Du könntest jetzt noch C:\Windows\System zur Path-Variable hinzufügen
PATH C:\DOS;C:\WINDOWS;C:\WINDOWS\SYSTEM
Aber das ist komisch, denn das dürfte eigentlich nicht nötig sein. Hast du die Kopien, die du unter C:\ hingeworfen hast dort auch wieder entfernt? Oder gammeln da jetzt win.com und win386.exe auch rum? Entferne diese ggf. sodass er auch wirklich aus dem Windows-Verzeichnis heraus startet.

Die Festplatte wird übrigens nicht das ewige Leben haben, falls du das wieder hingebogen bekommst, mach ein Backup. ;-)
--
Verloren hat, wer sich geschlagen gibt!

Dieser Post wurde am 16.12.2011 um 22:18 Uhr von commander_keen editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
018
17.12.2011, 02:03 Uhr
Aqua



@Nuwi: Hab mal eine optimalere Standardkonfiguration für deinen besagten PC auf Verdacht erstellt.

Die solltest du eigentlich verwenden können, wie sie ist, sollte den Rechner auch bisschen schneller machen und sollte auch ausreichend konventionellen Speicher bereitstellen..
Könnte dir auch das Ausführen von Memmaker.exe ersparen..





Wenn du nicht möchtest, dass Windows automatisch startet, setzt du einfach ein Rem vor Win.com
REM WIN.COM

Wievel Ram hatte der PC nochmal? Weil vielleicht kann man den Smartdrive Cache noch höher setzen..
--
Generic USB Massenspeichertreiber: DOS/Win3.1x-USB1+2 Win95B-USB1+Win95BUSBSupp Win98FE-USB1+2
Win98SE-USB1+2 WinNT4.0-USB1 DOS-PCMCIA-ATA bis zu 4 Sockets(Cardbus kompatibel) My pimped DOS6-WIN3 All4Win3-MP3

Dieser Post wurde am 17.12.2011 um 03:54 Uhr von Aqua editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
019
17.12.2011, 06:13 Uhr
Alf

Avatar von Alf

hä ?? deine eigene autoexec und config auf c hast so editiert ?
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
Seiten: -1- [ 2 ] [ 3 ]     [ Installation und Konfiguration ]  



Win31.de

powered by ThWboard 3 Beta 2.84-php5
© by Paul Baecher & Felix Gonschorek