Windows 3.1x Support Forum

Registrieren || Einloggen || Hilfe/FAQ || Suche || Memberlist || Home || Statistik || Kalender || Staff Willkommen Gast!
[ win31.de ] [ Impressum/Kontakt ] [ Über das Forum/Regeln ]

Windows 3.1x Support Forum » Installation und Konfiguration » Compaq Portable 386 und Wfw 3.11 ?! » Threadansicht

Autor Thread - Seiten: -1-
000
20.07.2006, 14:24 Uhr
Peter Dassow



Habe mal ne Frage, habe ein Compaq Portable 386 bei Ebay ersteigert, weil ich für meinen Kaypro Diskettenimages konvertieren möchte.
Jetzt habe ich erfahren, dass das Gerät keine EGA und auch keine CGA besitzt, sondern so ein Compaq Enhanced Color Graphics Board mit Plasmabildschirm und 640x400 Bildpunkten.
Brauche ich einen speziellen Treiber für die volle Auflösung (also nicht CGA, sondern 640x400 Punkte) und wenn ja, woher ? Auf der Compaq-Website gibt es jedenfalls die Treiber nicht mehr :-(
--
Infos zu alten CP/M Rechnern - auch hier zu finden: http://www.z80.eu :-)
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
001
20.07.2006, 16:52 Uhr
DosAmp
Administrator
Avatar von DosAmp

Funktioniert denn der VGA-Modus nicht?
--
DosAmp. Macht das Forum unsicher seit Sommer 2005.
System-Profile: Hauptrechner (C2D S775) – Zweitrechner (P4 S423)
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
002
20.07.2006, 17:27 Uhr
freaked
Moderator
Avatar von freaked

versuch mal irgendeinen der in win3.1 mitgelieferten treiber..das teil kann ja nicht allzu exostisch sein..genaue bezeichnung des notebooks hast du nicht?
--
Tips&Tricks - Community-based: www.freakedenough.at
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
003
22.07.2006, 22:38 Uhr
Peter Dassow




Zitat:
freaked postete
versuch mal irgendeinen der in win3.1 mitgelieferten treiber..das teil kann ja nicht allzu exostisch sein..genaue bezeichnung des notebooks hast du nicht?

Also: Das Gerät heisst genau so, wie ich es zuvor gepostet habe:
Compaq Portable 386

Zu dem Beitrag davor: Wir reden hier nicht von einem modernen PC !
Der Compaq Portable 386 hatte noch keine VGA-Karte, sondern so was wie eine "aufgemotzte" CGA Karte. Ich habe das Gerät noch nicht in der Hand halten können, wollte prophylaktisch schon mal das mit dem Video-Treiber vorklären.
Habe inzwischen mühselig *ohne dieses Forum* herausbekommen, dass es wohl zumindest für Windows 3.1 (nicht Wfw 3.11) einen "PLASMA.DRV" gab.
Na ich werd's wohl abwarten müssen und selbst ausprobieren... eventuell kann man ja in den INI-Dateien die Treiber von Windows 3.1 ins Wfw reinmogeln...

Gruss
Peter
--
Infos zu alten CP/M Rechnern - auch hier zu finden: http://www.z80.eu :-)
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
004
22.07.2006, 23:15 Uhr
Tim



Das mit dem Treiber sollte klappen, ich kann es natürlich nicht garantieren, Ich hab mal eben in der Hardwarekompatibilitätsliste von Windows 3.1 nachgeguckt, da ist der Compaq Portable 386 zumindest drin.
--
SIC TRANSIT GLORIA MUNDI!
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
005
26.07.2006, 12:05 Uhr
gabyde
Administrator
Avatar von gabyde

Peter,

die 3.1-Treiber laufen problemlos auch unter WfW 3.11 und umgekehrt. Das dürfte also das geringste Übel sein.
Ansonsten guck einfach mal bei der Installation, welche Treiber Dir angeboten werden. Vielleicht ist ja der passende schon dabei.

Das ganze klingt jedenfalls irgendwie schwer nach EGA, auch wenn Du schreibst, daß es kein EGA ist. Probier doch einfach mal EGA aus - und wenn's nicht funktioniert, kannst Du ja immer noch nen anderen Treiber nehmen.

Ciao, Gaby
--
Und eine Stimme sprach zu mir: lächle und sei froh, es könnte schlimmer kommen. Ich lächelte und war froh und es kam schlimmer...
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
006
26.07.2006, 19:36 Uhr
Tim



Also, ich hab mal gegoogelt und bin wie du auch schon gesagt hast, auf diese beiden Dateien getoßen:

PLASMA.3GR Compaq Portable plasma 386 enhanced mode display component
PLASMA.DRV Compaq Portable plasma display driver

Bei WfW 3.11 sind die nicht mehr dabei, aber dafür auch im Windows Resouce Kit 3.1. Was das dann letztlich ist, CGA oder EGA, keine Ahnung.
--
SIC TRANSIT GLORIA MUNDI!
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
007
01.08.2006, 21:42 Uhr
Peter Dassow




Zitat:
Tim postete
Also, ich hab mal gegoogelt und bin wie du auch schon gesagt hast, auf diese beiden Dateien getoßen:

PLASMA.3GR Compaq Portable plasma 386 enhanced mode display component
PLASMA.DRV Compaq Portable plasma display driver

Bei WfW 3.11 sind die nicht mehr dabei, aber dafür auch im Windows Resouce Kit 3.1. Was das dann letztlich ist, CGA oder EGA, keine Ahnung.

Hallo Tim, Danke für die Info über den Windows Resource Kit 3.1 (wobei ich gar nicht gewusst habe, dass es einen solchen schon gab).
Inzwischen bin ich etwas schlauer geworden... das Gerät, welches ich ersteigert hatte, ist in Wirklichkeit nur ein Compaq Portable III mit einer Compaq Portable 386 Tastatur (daher auch die Fehlinformation des Ebay-Verkäufers).
Ich habe ein installiertes Windows 3.0 mit PLASMA.DRV vorgefunden. Es ist - auch wenn Gaby davon scheinbar nicht zu überzeugen ist - tatsächlich keine VGA und keine EGA und auch keine CGA, sondern ein Treiber, der 640x400 Punkte auf dem Plasma-Display darstellt.
Leider habe ich nun ein schwerwiegenderes Problem: Der RTC-Baustein mit integrierter Lithium-Batterie, ein Dallas Real Time DS1287, hat seine Spannung verloren. Ein Replacement scheint der DS12887 zu sein (bei Reichelt.de noch zu haben), aber ich weiss es noch nicht genau - muss ich wohl ausprobieren.
Leider hat das Gerät nur 640 KB RAM (und nur einen 286), so dass Windows 3.0 bereits nur mit Speicherproblemen läuft. Ich denke, eine zeichenbasierte Oberfläche a la Quarterdecks Desqview oder PC/MOS würde mir auch schon reichen ;-)
Oder ich probiere mal CP/M-86 ...

Gruss
Peter
--
Infos zu alten CP/M Rechnern - auch hier zu finden: http://www.z80.eu :-)
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
008
02.08.2006, 18:57 Uhr
gabyde
Administrator
Avatar von gabyde

Hallo Peter,


Zitat:
Peter Dassow postete

...auch wenn Gaby davon scheinbar nicht zu überzeugen ist - tatsächlich keine VGA und keine EGA und auch keine CGA, sondern ein Treiber, der 640x400 Punkte auf dem Plasma-Display darstellt.

Ja, scheinbar Ich weiß schon, daß es kein EGA ist, denn wenn Du schreibst, daß es keins ist, dann glaube ich Dir
War ja nur ein Vorschlag, es einfach trotzdem mal auszuprobieren...

Wie wäre denn GEM oder NewDeal als Oberfläche? Ich kenne da die Anforderungen nicht, aber soll ja beides nicht schlecht sein.

Ciao, Gaby
--
Und eine Stimme sprach zu mir: lächle und sei froh, es könnte schlimmer kommen. Ich lächelte und war froh und es kam schlimmer...
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
009
03.08.2006, 01:55 Uhr
Tim



@Peter Dassow
Ich weiß ja nicht genau wie das Gerät aufgebaut ist, aber laut Google ist der RAM bis auf 6,6 MB erweiterbar und eine Expansion Box mit ISA-Steckplätzen soll es auch geben, dann wär Win3.1 kein Problem mehr, im Standart-Modus läuft schon ne ganze Menge. Allerdings wird da wohl wahrscheinlich nicht einfach dranzukommen sein, am besten du probierst einfach irgendwas aus, was dir naheliegt.
--
SIC TRANSIT GLORIA MUNDI!
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
010
04.08.2006, 09:08 Uhr
Peter Dassow




Zitat:
Tim postete
@Peter Dassow
Ich weiß ja nicht genau wie das Gerät aufgebaut ist, aber laut Google ist der RAM bis auf 6,6 MB erweiterbar und eine Expansion Box mit ISA-Steckplätzen soll es auch geben, dann wär Win3.1 kein Problem mehr, im Standart-Modus läuft schon ne ganze Menge. Allerdings wird da wohl wahrscheinlich nicht einfach dranzukommen sein, am besten du probierst einfach irgendwas aus, was dir naheliegt.

Da ich das Gerät schon geöffnet habe, muss ich Dich da enttäuschen (Google ist halt auch nicht so genau ;-)).
Die RAM-Expansion (nur LIM/EMS möglich) ist eine extra Platine, die ich mit Sicherheit (99,99999999999999999999999%) nicht mehr bekomme. Das Gerät ist sehr erweiterungsunfreundlich. Ich kann noch nicht mal das Diskettenlaufwerk ersetzen, weil ich eins ohne Drehknebel, sondern mit Druckknopf für den Auswurf bräuchte (die sind noch seltener).
Es stecken zwar zwei (komisch) SIMM-ähnliche Platinchen im Mainboard, aber die sehen sehr exotisch aus (keine normalen SIMMs, sondern kleiner).
Da wäre der Compaq Portable 386 (nicht III) wesentlich einfacher mit RAM erweiterbar gewesen.

Gruss
Peter
--
Infos zu alten CP/M Rechnern - auch hier zu finden: http://www.z80.eu :-)
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
011
04.08.2006, 09:12 Uhr
Peter Dassow




Zitat:
gabyde postete
Hallo Peter,


Zitat:
Peter Dassow postete

...auch wenn Gaby davon scheinbar nicht zu überzeugen ist - tatsächlich keine VGA und keine EGA und auch keine CGA, sondern ein Treiber, der 640x400 Punkte auf dem Plasma-Display darstellt.

Ja, scheinbar Ich weiß schon, daß es kein EGA ist, denn wenn Du schreibst, daß es keins ist, dann glaube ich Dir
War ja nur ein Vorschlag, es einfach trotzdem mal auszuprobieren...

Wie wäre denn GEM oder NewDeal als Oberfläche? Ich kenne da die Anforderungen nicht, aber soll ja beides nicht schlecht sein.

Ciao, Gaby

GEM (OpenGEM 5.0 ist perfekt für alte Rechner ohne Extended Memory!) ist tatsächlich eine sehr gute Option.
Ich weiss inzwischen, dass der AT&T 6300 und ein ganz bestimmter Olivetti AT-kompatibler (steht in der GEM Hardwareliste) der auch 640x400 Bildpunkte "macht", kompatibel zu dem Compaq Portable Grafikchip ist. Damit läuft auch GEM mit der vollen Auflösung. Windows 3.1 ist - man glaubt es wirklich kaum - einfach zu Hardware-hungrig :-(

Gruss
Peter
--
Infos zu alten CP/M Rechnern - auch hier zu finden: http://www.z80.eu :-)
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
012
04.08.2006, 16:51 Uhr
DosAmp
Administrator
Avatar von DosAmp


Zitat:
Windows 3.1 ist - man glaubt es wirklich kaum - einfach zu Hardware-hungrig :-(

Ohne VGA geht so richtig nix unter Win3.1, so scheint es...
Ansonsten kann ich auch OpenGEM empfehlen (leider gibt es wohl keine deutsche Version seit Anfang der 90er, das ließe sich aber ändern). Bei der Installation ist mir aufgefallen, wie stark das ganze sich mit Ataris, die ich mal vor Urzeiten benutzt habe, geähnelt hat.
In der aktuellen Version 5 gibt es auch mit netten 3D-Effekten ein bisschen Windows 3.x-Feeling.

http://gem.shaneland.co.uk/
--
DosAmp. Macht das Forum unsicher seit Sommer 2005.
System-Profile: Hauptrechner (C2D S775) – Zweitrechner (P4 S423)
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
013
05.08.2006, 20:31 Uhr
DosAmp
Administrator
Avatar von DosAmp

Um an obigen Beitrag anzuknüpfen: Wer würde gerne mithilfen, OpenGEM 5 auf Deutsch zu übersetzen? (Das wäre wieder etwas, das ich sonstwo an ein virtuelles Schwarzes Brett gehängen hätte, aber so muss ich wieder ein Thread "umfunktionieren". ) Alles, was man bräuchte, wäre das OpenGEM SDK, das allerdings mit 44 MB nicht für jede Internetverbindung erträglich ist. Man könnte die sprachspezifischen Dateien natürlich auch auf alle verteilen...

Falls jemand ebenfalls Interesse hätte (was ich allerdings bezweifle), soll er sich per PM bei mir melden.
--
DosAmp. Macht das Forum unsicher seit Sommer 2005.
System-Profile: Hauptrechner (C2D S775) – Zweitrechner (P4 S423)

Dieser Post wurde am 05.08.2006 um 20:32 Uhr von DosAmp editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
014
06.08.2006, 01:18 Uhr
Peter Dassow




Zitat:
DosAmp postete

Zitat:
Windows 3.1 ist - man glaubt es wirklich kaum - einfach zu Hardware-hungrig :-(

Ohne VGA geht so richtig nix unter Win3.1, so scheint es...
Ansonsten kann ich auch OpenGEM empfehlen (leider gibt es wohl keine deutsche Version seit Anfang der 90er, das ließe sich aber ändern). Bei der Installation ist mir aufgefallen, wie stark das ganze sich mit Ataris, die ich mal vor Urzeiten benutzt habe, geähnelt hat.
In der aktuellen Version 5 gibt es auch mit netten 3D-Effekten ein bisschen Windows 3.x-Feeling.
http://gem.shaneland.co.uk/

Hallo - das mit dem Hardware-Hungrig bezog sich eher auf Hauptspeicher und Prozessorleistung, weniger auf die Grafikkarte.
OpenGEM habe ich einen Beitrag über Deinen ja bereits erwähnt. Ich habe sogar LocoBASIC (Basic für GEM) wiedergefunden... für kleine Programmierarbeiten reicht das. Die deutsche Übersetzung würde sicherlich dem Englisch weniger mächtigen Leuten helfen... ich persönlich habe damit kein Problem, manchmal ist Englisch sogar verständlicher (weil die deutsche Übersetzung schlechter war).

Gruss
Peter
--
Infos zu alten CP/M Rechnern - auch hier zu finden: http://www.z80.eu :-)

Dieser Post wurde am 06.08.2006 um 01:19 Uhr von Peter Dassow editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
015
06.08.2006, 14:04 Uhr
DosAmp
Administrator
Avatar von DosAmp


Zitat:
Hallo - das mit dem Hardware-Hungrig bezog sich eher auf Hauptspeicher und Prozessorleistung, weniger auf die Grafikkarte.

Na gut, das war mir danach auch aufgefallen. Das Laptop ist halt insgesamt nicht so geeignet für Windows 3.1.

Zitat:
ich persönlich habe damit kein Problem, manchmal ist Englisch sogar verständlicher

Macht ja nix, das hat doch sicher jeder schon mal erlebt. Für mich ist es z. Zt. auch nicht so wesentlich wichtig, OpenGEM 5 auf Deutsch zu haben. Insbesondere, da sich meine angebliche Sicherungskopie von Win3.11 als WfW entpuppt hat. Da gibts jetzt genug zum Netzwerk-Basteln
--
DosAmp. Macht das Forum unsicher seit Sommer 2005.
System-Profile: Hauptrechner (C2D S775) – Zweitrechner (P4 S423)
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
016
24.08.2006, 12:45 Uhr
Peter Dassow




Zitat:
DosAmp postete

Zitat:
Hallo - das mit dem Hardware-Hungrig bezog sich eher auf Hauptspeicher und Prozessorleistung, weniger auf die Grafikkarte.

Na gut, das war mir danach auch aufgefallen. Das Laptop ist halt insgesamt nicht so geeignet für Windows 3.1.

Zitat:
ich persönlich habe damit kein Problem, manchmal ist Englisch sogar verständlicher

Macht ja nix, das hat doch sicher jeder schon mal erlebt. Für mich ist es z. Zt. auch nicht so wesentlich wichtig, OpenGEM 5 auf Deutsch zu haben. Insbesondere, da sich meine angebliche Sicherungskopie von Win3.11 als WfW entpuppt hat. Da gibts jetzt genug zum Netzwerk-Basteln

Habe inzwischen QRAM 2.02 ausprobiert. Tja, wenn der Rechner physisch nur 640 KB RAM hat, kann er auch mit den tollsten Tricks keine UMB-Bereiche anbieten.
Schade. Das Gerät ist ansonsten wirklich eine "tolle Kiste" und verbraucht auch nicht viel Platz. Werde es wohl wieder verkaufen... :-(
--
Infos zu alten CP/M Rechnern - auch hier zu finden: http://www.z80.eu :-)

Dieser Post wurde am 24.08.2006 um 12:45 Uhr von Peter Dassow editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
017
17.11.2012, 14:44 Uhr
freaked
Moderator
Avatar von freaked

http://www.freakedenough.at/infoseiten/read.php?id=66 für alle die WfW3.11 zum laufen bekommen möchten.
--
Tips&Tricks - Community-based: www.freakedenough.at
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
Seiten: -1-     [ Installation und Konfiguration ]  



Win31.de

powered by ThWboard 3 Beta 2.84-php5
© by Paul Baecher & Felix Gonschorek