Windows 3.1x Support Forum

Registrieren || Einloggen || Hilfe/FAQ || Suche || Memberlist || Home || Statistik || Kalender || Staff Willkommen Gast!
[ win31.de ] [ Impressum/Kontakt ] [ Über das Forum/Regeln ]

Windows 3.1x Support Forum » Installation und Konfiguration » Touchscreen-Treiber in Win3.1 einstellen? WO?WIE? » Threadansicht

Autor Thread - Seiten: -1-
000
06.10.2006, 13:47 Uhr
futuretec



Hallo zusammen!
Ich habe ein altes MS-DOS Kassensystem mit Touchscreen, eingebautem Tastenfeld und Thermobondrucker.

Mittlerweile habe ich es geschafft MS-DOS 6.2 so weit zu bringen, dass der Touchscreen endlich in DOS geht.
---
Einträge in die config.sys:

DEVICE=C:\DOS\SETVER.EXE
DEVICE=C:\DOS\HIMEM.SYS
DOS=HIGH
COUNTRY=049,850,C:\DOS\COUNTRY.SYS
DEVICE=C:\DOS\DISPLAY.SYS CON=(EGA,,1)
FILES=30
DEVICEHIGH=C:\DOS\POSIO.SYS /K:B0 /B:B1 /M:B2 /D:B3 /P:B6 /T:B7 /R /U:2,0
DEVICEHIGH=C:\DOS\SIO.SYS /S:B4
DEVICEHIGH=C:\DOS\POSMW.SYS /I:61
DEVICEHIGH=C:\DOS\KEY5300.SYS /T:C:\DOS\KEYBOARD.KTB
STACKS=9,256
---

Zugleich ist Win 3.1 installiert, nun aber das Problem dass in Windows 3.1 der Touchscreen nicht geht.
Was muss ich in Win noch einstellen dass er auch da geht.
[der thermobondrucker lässt sich nur über hexport 0x4242 ansteuern .. bloß wie das geht ist mir auch rätselhaft .. aber das ist ja was anderes]

THX
futuretec

Dieser Post wurde am 06.10.2006 um 19:19 Uhr von gabyde editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
001
06.10.2006, 19:34 Uhr
DosAmp
Administrator
Avatar von DosAmp

Hmmm... könntest du ein wenig erläutern, was alles damit nicht in Windows geht? Hast du "nur" keinen Maus-Support oder ist auch keine Tastenfeld-Eingabe möglich?
Windows ist von Haus aus dafür eingestellt, mit seriellen oder PS/2-Mäusen bedient zu werden und ignoriert sämtliche DOS-Maustreiber in der Regel.
Ggf. gibt es schon einen Treiber dafür im Windows-Verzeichnis. Mache mal eine Liste von *.drv-Dateien in <Windows-Verzeichnis>\SYSTEM und ggf. in \DOS oder sonstigen Ordner, falls sich da welche befinden. Schreib dir auch mal ab, was in der SYSTEM.INI in der Zeile

Zitat:
[boot]

[...]

mouse.drv=<treibername>.drv

steht.
--
DosAmp. Macht das Forum unsicher seit Sommer 2005.
System-Profile: Hauptrechner (C2D S775) – Zweitrechner (P4 S423)
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
002
06.10.2006, 20:52 Uhr
futuretec



hi!

also eintrag in der system.ini:

mouse.drv=MOUSE.DRV

folgende drv-dateien sind in system:
comm.drv
keyboard.drv
mciseq.drv
mciwave.drv
midimap.drv
mmsound.drv
mouse.drv
nomouse.drv
sound.drv
system.drv
timer.drv
tty.drv
vga.drv
vga_19.drv

drv-dateien im ordner DOS:
vga_19.drv

ich habe leider keine drv-dateien vom kassensystem
alles nur die SyS-Dateien
die einzige DRV-Datei ist "vga_19.drv" (hat aber glaube ich nichts mit dem touchscreen zu tun)
wie binde ich dann die driver ein !?

bitte helft mir ^^
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
003
06.10.2006, 21:19 Uhr
DosAmp
Administrator
Avatar von DosAmp

vga_19.drv ist wahrscheinlich ein Displaytreiber, den du bei Interesse wie folgt austesten könntest:

Zitat:
; Standard-Displaytreiber deaktivieren
;display.drv=vga.drv
display.drv=vga_19.drv

Falls da bereits display.drv=vga_19.drv steht, wird er schon sowieso genutzt.
Falls das nicht geht, Semikolon vor der zweiten Zeile sowie neue Zeile wieder löschen...

Es ist allerdings seltsam, dass nomouse.drv vorhanden ist. Könntest du noch mal danach in der system.ini (Suche nach "nomouse") suchen und alles gefundene ggf. posten?
--
DosAmp. Macht das Forum unsicher seit Sommer 2005.
System-Profile: Hauptrechner (C2D S775) – Zweitrechner (P4 S423)

Dieser Post wurde am 06.10.2006 um 21:24 Uhr von DosAmp editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
004
06.10.2006, 22:46 Uhr
futuretec



also in der system.ini ist keinerlei "nomouse"-Eintrag zu finden

wenn ich den display-driver umstelle kommt "Konnte nicht geladen werden: vga_19.drv"

cu
futuretec
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
Seiten: -1-     [ Installation und Konfiguration ]  



Win31.de

powered by ThWboard 3 Beta 2.84-php5
© by Paul Baecher & Felix Gonschorek