Windows 3.1x Support Forum

Registrieren || Einloggen || Hilfe/FAQ || Suche || Memberlist || Home || Statistik || Kalender || Staff Willkommen Gast!
[ win31.de ] [ Impressum/Kontakt ] [ Über das Forum/Regeln ]

Windows 3.1x Support Forum » MS DOS 1.x-8.x » suspekte einträge in der autoexec.bat » Threadansicht

Autor Thread - Seiten: -1-
000
21.12.2006, 11:43 Uhr
honx
Moderator
Avatar von honx

hier mal ein kleiner auszug aus meiner autoexec.bat:

SET CTCM=C:_\DRIVERS\CTCM
C:_\DRIVERS\CTCM\CTCU /S /W=C:_\WINDOWS
LH /L:0;1,45968 /S C:_\DOS\smartdrv.exe /X
...
SET BLASTER=A220 I5 D1 H5 P330 T6

die underlines bitte wegdenken, die dienen hier nur der smilieverhinderung...

dieses ctcm-dingens ist der soundkartentreiber.
nun die frage: ich hatte diese beiden zeilen bereits auskommentiert,
nur die zeile "set blaster..." war aktiv und ich hatte trotzdem sound unter dos.
also wofür brauch ich diese dinger dann überhaupt?
laut mem belegt diese ctcu nämlich 340kb meines wertvollen konventionellen speichers.
und verhindert damit den start von biing, welches zu wenig konv. speicher findet.
ohne diese zwei zeilen kann ich biing starten, mit sound und allem drum und dran!

welchen zweck erfüllt dieser "treiber" eigentlich?

und dann hätt ich noch ne dumme frage: was hat das bitte mit smartdrv.exe auf sich?
wofür wird das denn gebraucht?
--
gOmp ist wieder da!

Dieser Post wurde am 21.12.2006 um 11:48 Uhr von honxi.4.amiga editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
001
21.12.2006, 21:24 Uhr
~ChrisKuhli



Hallo honxi!

Der CtCm ist erforderlich damit bestimmte Sw die SB ansprechen kann... Die Plug-and-Play Unterstützung!

Du kannst es ohne probieren, aber u.U. bleibt die Karte dann unter Windows stumm.

SmartDrive ist der Festplattencache der je nach Konfiguration, etwa bei neuerer Hardware/ schneller Festplatte gar nicht erforderlich ist!

Zum Speicherproblem:
Verwendest Du evtl. in der config.sys den emm386.exe ?
Dann sollte zu Beginn drinstehen:

device=c:_dos\himem.sys
device=c:_dos\emm386.exe ram min=0
dos=high,umb

1. Eintrag bringt XMS-Speicher (je nach DOS-Version auch mit Parameter "/testmem:off")
2. Zeile bringt EMS-Speicher und Upper Memory (PC ist dann aber im Protected Mode virtueller 386)
3. Zeile stellt ein dass DOS den HMA nutzen soll, und dass Treiber und TSR in Upper Memory geladen werden können.

Nun alles was danach hochgeladen werden soll in config.sys mit devicehigh und in autoexec.bat mit loadhigh oder kurz lh ausführen.

Achtung:
Es kann sein dass nicht alles hochgeladen werden kann (SmartDrive z.B. mag kein LoadHigh/Lh).

Natürlich übernehme ich keine Gewähr dass das ganze klappt
Bisherige himem, emm386 und dos zeilen bitte ersetzen, um zu probieren!


Weihnachtliche Grüße,
Chris

Dieser Post wurde am 21.12.2006 um 21:33 Uhr von ChrisKuhli editiert.
Seitenanfang Seitenende
(Gast) Zitatantwort || Editieren || Löschen || IP
002
23.12.2006, 21:12 Uhr
honx
Moderator
Avatar von honx

danke, ich werd das mal ausprobieren.

aber eine frage hätte ich noch:

und zwar hab ich in meiner config.sys die zeile device=c:_\dos\emm386.exe noems
soweit ich das da rauslese, ist der ems damit deaktiviert.
wenn ich aber nun das noems rausnehme und durch mem= ersetze,
dann hab ich laut mem noch weniger konventionellen speicher zur verfügung.

also wie soll ich in diesem fall weiter verfahren?
--
gOmp ist wieder da!
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
003
24.12.2006, 05:08 Uhr
~ChrisKuhli



Hallo!

Du kannst zwischen verschiedenen Optionen wählen...,

Ich weiss nicht welche *bei dir* die besten sind.

Ems benötigt Seitenrahmen! "min=0" heisst ems wird erst auf Anforderung verfügbar.

Vielleicht behagt Dir ja Memmaker (nur in MS-DOS 6.x)?
Falls ja teste den, der macht das alles automatisch.

Weihnachtliche Grüße,
Chris

Dieser Post wurde am 24.12.2006 um 05:17 Uhr von ChrisKuhli editiert.
Seitenanfang Seitenende
(Gast) Zitatantwort || Editieren || Löschen || IP
004
24.12.2006, 15:19 Uhr
honx
Moderator
Avatar von honx

den memmaker hab ich wohl drüberlaufen lassen,
der hat mir eben den besagten eintrag in der config.sys beschert:

device=c:_\dos\emm386.exe noems
--
gOmp ist wieder da!
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
005
05.01.2007, 00:08 Uhr
commander_keen

Avatar von commander_keen

memmaker fragt dich doch, ob du EMS brauchst oder nicht, also hast du wohl mit nein geantwortet
Wenn du keinen brauchst, ist doch gut mit NOEMS...
--
Verloren hat, wer sich geschlagen gibt!
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
Seiten: -1-     [ MS DOS 1.x-8.x ]  



Win31.de

powered by ThWboard 3 Beta 2.84-php5
© by Paul Baecher & Felix Gonschorek