Windows 3.1x Support Forum

Registrieren || Einloggen || Hilfe/FAQ || Suche || Memberlist || Home || Statistik || Kalender || Staff Willkommen Gast!
[ win31.de ] [ Impressum/Kontakt ] [ Über das Forum/Regeln ]

Windows 3.1x Support Forum » MS DOS 1.x-8.x » XCOPY funktioniert nicht nach Gemeinsame Dateien.. » Threadansicht

Autor Thread - Seiten: -1-
000
14.01.2007, 18:14 Uhr
Stefanotis



hallo
Ich versuche über eine Batch Datei am Ende der Windows Installation einige Dateien aus dem Ordner Cinstall nach CProgrammeGemeinsame DateienAheadAudioPlugins zu kopieren. genauer gesagt, muss ich eingige der vorhandenen Dateien durch aktuellere ersetzten.

Nun versuche ich das über folgende befehle:

xcopy /y Cinstall\plugins C:Programme\Gemeinsame Dateien\Ahead\AudioPlugins

dann bekomme ic jedesmal den fehler "Unzulässige Parameterzahl


das selbe passiert mit dem normalen copy, wenn ich versuche jede Datei einzeln herüber zu kopieren. Woran liegt das?! Ist das Verzeich nis geschützt’und ich kann den Schutz nicht aufheben? Ich habe mal nachgesehen, und entdeckt, dass ein Schreibschutz vorliegt, aber selbst wenn ich den (manuell oder mit DOS per attrib= ausschalte geht es nicht...hat jemand eine Idee?

Dieser Post wurde am 14.01.2007 um 18:15 Uhr von Stefanotis editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
001
14.01.2007, 18:23 Uhr
DosAmp
Administrator
Avatar von DosAmp

Das geht aus einem einfachen Grund nicht so. Du musst Verzeichnisse mit Leerzeichen in Anführungsstriche setzen, also das ganze so aufrufen:

Quellcode:
xcopy /y C:\install\plugins "C:\Programme\Gemeinsame Dateien\Ahead\AudioPlugins"

Falls dich XCOPY fragt, ob das Ziel eine Datei oder ein Verzeichnis ist, antworte mit V (Verzeichnis).

Nur der cd-Befehl (und auch nur unter Win2000/XP) erlaubt dir, Verzeichnisnamen mit Leerzeichen ohne Anführungsstriche zu schreiben. Ansonsten ist das bei allen Kommandozeilen-Befehlen Pflicht, damit die Programme das verstehen (daher auch "%1" bei der Kommandozeilen-Übergabe bei Dateizuordnungen im Gegensatz zu Windows 3.1 mit nur %1...)
--
DosAmp. Macht das Forum unsicher seit Sommer 2005.
System-Profile: Hauptrechner (C2D S775) – Zweitrechner (P4 S423)

Dieser Post wurde am 14.01.2007 um 19:31 Uhr von DosAmp editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
Seiten: -1-     [ MS DOS 1.x-8.x ]  



Win31.de

powered by ThWboard 3 Beta 2.84-php5
© by Paul Baecher & Felix Gonschorek