Windows 3.1x Support Forum

Registrieren || Einloggen || Hilfe/FAQ || Suche || Memberlist || Home || Statistik || Kalender || Staff Willkommen Gast!
[ win31.de ] [ Impressum/Kontakt ] [ Über das Forum/Regeln ]

Windows 3.1x Support Forum » Installation und Konfiguration » ...allgemeine Schutzverletzung im Modul SHELL.DLL... » Threadansicht

Autor Thread - Seiten: -1-
000
06.08.2007, 20:38 Uhr
werner365



Windwos 3.1 ist gestartet. Beim ersten Öffnen einer Software (z.B. Excel, Corel, aber auch DateiManager) kommt folgende Fehlermeldung: "In Ihrer Anwendung ist ein Fehler aufgetreten: Schließen/Ignorieren". Klicke ich auf "Ignorieren", klappt meistens der Start des Programmes, aber nicht immer.

Klicke ich dagegen auf "Schließen" kommt folgende Meldung: "Fehler im Anwendungsprogramm. Das Programm verursacht allgemeine Schutzverletzung im Modul SHELL.DLL an Adresse 0002:0171". Mit dem Anklicken des Diaglofeldes verschwindet dieses und die Software schließt auch. Ab jetzt kann ich jede Software ohne Fehlermeldung starten.

Habe scandisk durchgeführt --> Keine Fehler auf der Platte.
Habe shell.dll neu installiert --> Fehler tritt weiter auf.

Was bewirkt eigentlich diese shell.dll? Welche Adresse ist gemeint? Wie kann ich das Problem beheben. Vielen Dank schonmal vorab für Eure Hilfe.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
001
06.08.2007, 22:02 Uhr
honx
Moderator
Avatar von honx

versuch mal, die platte zu defragmentieren. vielleicht gibts da doch ein kleines problem, welches scandisk nicht findet.
sollte das auch ergebnislos bleiben, kann ich meinerseits nur noch auf defekten arbeitsspeicher tippen.
--
gOmp ist wieder da!
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
002
06.08.2007, 22:15 Uhr
werner365



Platte ist frisch defragmentiert und Fehler tritt trotzdem auf. An den Arbeitsspeicher habe ich auch schon gedacht. Der Fehler tritt aber immer logisch an der gleichen Stelle auf. Müsste es nicht so sein, sollte wirklich ein Bereich des RAM defekt sein, dass alle möglichen Fehler auftreten, da ja nicht immer die gleichen Dateien im gleichen Bereich des RAM abgelegt werden?
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
003
06.08.2007, 23:42 Uhr
commander_keen

Avatar von commander_keen

RAM Fehler sind unberechenbar und testen kostet nihts: Also memtest86 runterladen und schlauer werden...
--
Verloren hat, wer sich geschlagen gibt!

Dieser Post wurde am 07.08.2007 um 10:02 Uhr von gabyde editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
004
07.08.2007, 00:58 Uhr
honx
Moderator
Avatar von honx

stimmt, die testmöglichkeit mit memtest86 hab ich gar nicht bedacht.
alternativ könntest du, sofern mehrere ram-bausteine im rechner stecken,
mal einen nach dem anderen ausbauen und gucken, wann der fehler auftritt.
--
gOmp ist wieder da!
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
005
10.08.2007, 18:19 Uhr
werner365



Nach memtest86 sind keine Fehler vorhanden. Ist denn bei der Adressangabe in der Fehlermeldung bein Berichim Arbeitsspeicher gemeint oder innerhalb der shell.dll?
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
006
11.08.2007, 13:29 Uhr
commander_keen

Avatar von commander_keen

Hast du denn mal versucht die Datei zu ersetzen mit einer vom Installationsdatenträger o.ä.? Nicht dass sie beschädigt ist...

ggf. bügel Win eben nochmal drüber...
--
Verloren hat, wer sich geschlagen gibt!
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
007
11.08.2007, 13:44 Uhr
honx
Moderator
Avatar von honx

die datei hat er schonmal neu installiert, kriegt damit den fehler aber nicht weg.

ne windows-neuinstallation könnte man mal versuchen, vielleicht bringts was.

zur frage mit der adressangabe, damit ist afaik die adresse gemeint,
die diese datei im speicher belegt, sprich ram. ich kann mich aber auch irren.
--
gOmp ist wieder da!

Dieser Post wurde am 11.08.2007 um 13:44 Uhr von honxi4amiga editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
008
11.08.2007, 13:59 Uhr
werner365



Ja, eine Lösung wäre natürlich eine Win-Neuinstallation. Dagegen wehre ich mich immer ein wenig, da dann auch die ganze Software mit ihren Einstellungen auch neu installiert werden muss. Vielleicht fällt hat ja irgendjemand noch eine gute Idee...
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
009
11.08.2007, 14:20 Uhr
commander_keen

Avatar von commander_keen

In Win3.x speichert die meiste software ihr Einstellungen doch noch in ini-Dateien, so viel kann da doch gar nicht verloren gehen bzw. mache davon ein backup...
--
Verloren hat, wer sich geschlagen gibt!
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
010
19.08.2007, 22:32 Uhr
Helix

Avatar von Helix

die Shell.dll ist die Bibliothek die API Aufrufe koordiniert ...
Ich hatte die Probleme auch mal , lag an meinem Treiber für die
Diamond GraKa..
--
"640 KB Ram sind mehr als irgendein Programm jemals benötigen wird."
- (Bill Gates - 1981)
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
Seiten: -1-     [ Installation und Konfiguration ]  



Win31.de

powered by ThWboard 3 Beta 2.84-php5
© by Paul Baecher & Felix Gonschorek