Windows 3.1x Support Forum

Registrieren || Einloggen || Hilfe/FAQ || Suche || Memberlist || Home || Statistik || Kalender || Staff Willkommen Gast!
[ win31.de ] [ Impressum/Kontakt ] [ Über das Forum/Regeln ]

Windows 3.1x Support Forum » MS DOS 1.x-8.x » MS DOS 7.1 und WFW mit Netzwerkunterstützung » Threadansicht

Autor Thread - Seiten: -1-
000
16.11.2007, 11:09 Uhr
xdavid



Hallöle,

ich bin mir nicht ganz sicher, ob das nun hierher gehört oder in eine Win-Gruppe...

Ich habe spaßeshalber - das ganze erfüllt keinerlei produktiven Zweck - den reinen DOS-Teil von Windows 98 SE auf eine virtuelle Festplatte installiert (bzw. ein installiertes W98SE auf den reinen DOS-Teil reduziert) - aber das Zusammenspiel mit WFW 3.11 macht nicht so richtig Spaß, vor allem, wenn es um den Netzwerk-Teil von WFW 3.11 geht.

Betreibe ich den Netzwerkteil von WFW 3.11 mit dem alten PC DOS 2000, funktioniert alles. Boote ich aber MS DOS 7.1, so funktioniert zwar c:\wfw311\net start, und ich kann mich mit net logon auch anmelden, bekomme aber weder mit WFW 3.11 noch mit net view Zugriff auf freigegebene Ressourcen, seien es Drucker oder Verzeichnisse. net view behauptet (aus dem Gedächtnis zitiert), es könne nicht auf die Serverliste zugreifen.

Beim Start von WFW bekomme ich drei Blue Screens (VxD Dynamic Link Aufrufe), die ich zwar wegklicken kann, aber dann sagt WFW im grafischen Modus: "Netzwerk wurde nicht gestartet... Netzwerktreiber nicht geladen".

net config jedenfalls sieht gut aus.

Was mich irritiert: In der autoexec.bat wird net start ausgeführt, ohne Fehler. Gebe ich aber später net stop ein, behauptet er, der Dienst sei nicht gestartet worden. Gebe ich aber net start ein, heißt es plötzlich doch, der Dienst sei gestartet worden. In mem /c finde ich die Treiber allerdings.

Wie dem auch sei... Ist es schon einmal jemanden gelungen, WFW 3.11 mitsamt Netzwerkunterstützung unter MS DOS 7.1 zu benutzen? Wenn ja, welche Tricks gibt es?

Ich bin jedenfalls sowohl in einem virtuellen PC (WFW unter MS DOS 7.1 installiert) als auch auf meinem Thinkpad (MS DOS 7.1 dem bereits installierten WFW 3.11 untergeschoben) gescheitert. OSR2FIX habe ich beachtet.


Grüßle,

Michael

Dieser Post wurde am 16.11.2007 um 16:02 Uhr von DosAmp editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
001
16.11.2007, 16:18 Uhr
DosAmp
Administrator
Avatar von DosAmp


Zitat:
Wie dem auch sei... Ist es schon einmal jemanden gelungen, WFW 3.11 mitsamt Netzwerkunterstützung unter MS DOS 7.1 zu benutzen? Wenn ja, welche Tricks gibt es?

Ich kann nur soviel sagen, dass ich dies schon mal (auf der in meiner Signatur als "Server" ausgewiesenen Kiste) hinbekommen habe. Ich hatte mir einst ebenfalls spaßeshalber aus einer Win98-Bootdiskette eine MS-DOS-7.1-Diskette erstellt und späterhin mithilfe der Möglichkeiten von GRUB4DOS eine Pseudo-Festplatteninstallation (Abbild der Diskette wird in den RAM kopiert und MS-DOS wird von dieser virtuellen Diskette gestartet) hinbekommen, mit der WfW 3.11 in Ordnung mit den NDIS2-Treibern meiner 100mbit-Karte lief. Allerdings war mir das auch nicht im ersten Anlauf gelungen, teilweise hängte sich der Netzwerktreiber und teilweise Windows ohne offensichtliche Gründe auf. Solange aber mindestens der Netzwerktreiber lief, funktionierten die Netzwerk-Konsolentools aber einwandfrei.
Unter Virtual PC 2004 verhielt sich das bei mir ähnlich.
--
DosAmp. Macht das Forum unsicher seit Sommer 2005.
System-Profile: Hauptrechner (C2D S775) – Zweitrechner (P4 S423)

Dieser Post wurde am 16.11.2007 um 16:19 Uhr von DosAmp editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
002
17.11.2007, 18:51 Uhr
Estron Dekal




Zitat:
xdavid postete
Boote ich aber MS DOS 7.1, so funktioniert zwar c:\wfw311\net start, und ich kann mich mit net logon auch anmelden, bekomme aber weder mit WFW 3.11 noch mit net view Zugriff auf freigegebene Ressourcen, seien es Drucker oder Verzeichnisse. net view behauptet (aus dem Gedächtnis zitiert), es könne nicht auf die Serverliste zugreifen.

Kenne ich sowohl von (NDIS2-)Treiberproblemen als auch von der Browsemaster-Geschichte.
Welche Netzwerkkarte, welcher Treiber, welche Version? Außerdem: Ist PCI-Busmastering im BIOS aktiviert? Wird der Treiber in Hardware-UMBs (wie von UMBPCI) geladen? Das könnte beides Probleme machen, falls der Treiber Busmastering verwendet.
Ansonsten mal versuchen, Freigaben eines auf jeden Fall erreichbaren Windows-Rechner direkt mit NET USE zu mappen. (Am besten eignet sich hierzu Windows 98 als "Server", da man dort keine Probleme mit nötigen Benutzern hat.)
Welches Protokoll verwendest du mit WfW 3.11?


Zitat:
xdavid postete
Beim Start von WFW bekomme ich drei Blue Screens (VxD Dynamic Link Aufrufe), die ich zwar wegklicken kann, aber dann sagt WFW im grafischen Modus: "Netzwerk wurde nicht gestartet... Netzwerktreiber nicht geladen".

Hm... zu den Bluescreens... System.ini-Eintrag vorgenommen, der hier beschrieben wird? Netzwerk ist natürlich klar.


Zitat:
xdavid postete
Was mich irritiert: In der autoexec.bat wird net start ausgeführt, ohne Fehler. Gebe ich aber später net stop ein, behauptet er, der Dienst sei nicht gestartet worden. Gebe ich aber net start ein, heißt es plötzlich doch, der Dienst sei gestartet worden. In mem /c finde ich die Treiber allerdings.

Ist die Datei IFSHLP.SYS geladen? Wenn ja, welche Version? (Genauer: Aus welchem Betriebssystem!) Außerdem: In der CONFIG.SYS oder mit einem Kommandozeilentool (DEVLOAD / LOADSYS / CTLOAD) geladen? Ich hatte vor kurzem einen SEHR ähnlichen Fehler, da ich aus Versehen versuchte, den Server des DOS-Workgroup-Add-Ons mit der Win4.1 IFSHLP.SYS zu betreiben.


Zitat:
xdavid postete
Wie dem auch sei... Ist es schon einmal jemanden gelungen, WFW 3.11 mitsamt Netzwerkunterstützung unter MS DOS 7.1 zu benutzen? Wenn ja, welche Tricks gibt es?

Win3.1x mit Netzwerk werde ich noch versuchen, zwei wichtige Tipps zum MSClient / DOS-Workgroup-Add-On kann ich aber schon geben:
* Zumindest mit FAT32-Dateisystem entgegen vieler Empfehlungen auf gar keinen Fall irgendeine SHARE.EXE verwenden!! (Weder ROM-DOS-, PC-DOS- noch FreeDOS-Share!!) Das NOSHARE-Programm auf dieser Seite funktionierte ganz gut als Ersatz, ist aber zumindest für den reinen Client nicht nötig, für WfW grundsätzlich wahrscheinlich auch nicht. Vielleicht sollte man auch die VSHARE.386 aus WfW nicht laden, allerdings hatte ich Win3.x noch nicht so oft auf MS-DOS 7.10 laufen.
* LOADSYS / CTLOAD / TSR Utilities vermeiden. Nicht FAT32 kompatibel, eventuell deswegen auch überhaupt inkompatibel zu MS-DOS 7.10. Neuestes DEVLOAD aus FreeDOS funktionierte zwar bei mir, aber trotzdem lieber nicht benutzen.

Außerdem in WfW zumindest vorerst sowohl 32-Bit Disk Access als auch 32-Bit File Access ausschalten. Soll beides unter manchen Umständen zu Problemen führen.
(BTW: Wer hat es geschafft, mit WfW und MS-DOS 7.10 eine permanente Swapdatei für Windows einzurichten?)


Zitat:
xdavid postete
Ich bin jedenfalls sowohl in einem virtuellen PC (WFW unter MS DOS 7.1 installiert) als auch auf meinem Thinkpad (MS DOS 7.1 dem bereits installierten WFW 3.11 untergeschoben) gescheitert. OSR2FIX habe ich beachtet.

Wie oben gesagt - auch die System.ini-Modifikation PageOverCommit könnte helfen, soll für Systeme mit mehr als 256 MiB Arbeitsspeicher nötig sein. Ich würde rein aus Gefühl heraus außerdem immer eine Neuinstallation vorschlagen.

Falls du die Zeit hast, versuche doch mal, den MSClient 3.0 unter MS-DOS 7.10 zum Laufen zu bringen. Dann wüsstest du nebenbei auch, ob die Netzwerkkartentreiber funktionieren.

Estron

Dieser Post wurde am 17.11.2007 um 20:49 Uhr von DosAmp editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
003
01.02.2008, 11:00 Uhr
xdavid



Hallo,

Schande über mich, daß ich bisher nicht geantwortet habe...

Wie dem auch sei, es funktioniert jetzt (eigentlich mittlerweile schon eine ganze Weile...).

Mein Fehler war der falsche IFSHLP.SYS; ich hatte den aus Windows 98 verwendet. Mit dem aus WfW 3.11 tut es.

Der Tip mit "PageOverCommit=2" ändert dagegen bei mir gar nichts am Verhalten von WfW 3.11 unter MS DOS 7.1.

Und ja, der 32-Bit-Zugriff auf Laufwerk bzw. Dateien funktioniert ebenso wenig wie die permanente Auslagerungsdatei.

Auch wenn es spät kommt: Danke für die Tipps :-)


Grüßle,

Michael
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
Seiten: -1-     [ MS DOS 1.x-8.x ]  



Win31.de

powered by ThWboard 3 Beta 2.84-php5
© by Paul Baecher & Felix Gonschorek